View Issue Details

IDProjectCategoryView StatusLast Update
0007529CentOS-7plymouthpublic2014-08-23 16:00
Reporterjfriedrich Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version7.0-1406 
Summary0007529: Plymouth boot screen not shown
DescriptionWhen using minimal install and installing on either VMware Fusion 6.0.4 or VMware vSphere 5.5, there is not plymouth boot screen. By default there are 3 to 5 kernel messages on top, but the rest of the screen is blank until the login prompt is displayed. The configuration, especially grub config, is not touched at this point.
Steps To Reproduce* Install CentOS 7.0 in VMware Fusion 6.0.4 or VMware vSphere 5.5
* Use minimal install
* Boot into system
Additional InformationI have tried several boot options like "plymouth.enable=1" or replacing/removing rhgb, all to no avail. also changing the default theme of plymouth and rebuilding the initramfs did not help. I can use the option "vga=0x0367" and use the FB device. Also I tried to use the latest VMware tools and the open-vm-tools provided with the distribution, no difference so far.

If i remove 'rhgb quiet' from the console, and add the above vga option, I get a high res FB console with all the details and info messages that usually occur during boot up.

This is the graphics card information from the VM:

00:0f.0 VGA compatible controller: VMware SVGA II Adapter (prog-if 00 [VGA controller])
    Subsystem: VMware SVGA II Adapter
    Flags: bus master, medium devsel, latency 64, IRQ 16
    I/O ports at 1070 [size=16]
    Memory at e8000000 (32-bit, prefetchable) [size=128M]
    Memory at fe000000 (32-bit, non-prefetchable) [size=8M]
    [virtual] Expansion ROM at c0000000 [disabled] [size=32K]
    Capabilities: [40] Vendor Specific Information: Len=00 <?>
    Kernel driver in use: vmwgfx

This is the drm info from dmesg:

[ 1.819119] [drm] Initialized drm 1.1.0 20060810
[ 2.246093] [drm] Capabilities:
[ 2.246098] [drm] Rect copy.
[ 2.246099] [drm] Cursor.
[ 2.246100] [drm] Cursor bypass.
[ 2.246100] [drm] Cursor bypass 2.
[ 2.246100] [drm] 8bit emulation.
[ 2.246101] [drm] Alpha cursor.
[ 2.246102] [drm] Extended Fifo.
[ 2.246102] [drm] Multimon.
[ 2.246102] [drm] Pitchlock.
[ 2.246103] [drm] Irq mask.
[ 2.246103] [drm] Display Topology.
[ 2.246104] [drm] GMR.
[ 2.246104] [drm] Traces.
[ 2.246105] [drm] GMR2.
[ 2.246105] [drm] Screen Object 2.
[ 2.246106] [drm] Max GMR ids is 64
[ 2.246107] [drm] Max GMR descriptors is 4096
[ 2.246108] [drm] Max number of GMR pages is 196608
[ 2.246108] [drm] Max dedicated hypervisor surface memory is 786432 kiB
[ 2.246109] [drm] VRAM at 0xe8000000 size is 77824 kiB
[ 2.246110] [drm] MMIO at 0xfe000000 size is 2048 kiB
[ 2.246114] [drm] global init.
[ 2.250854] [drm] It appears like vesafb is loaded. Ignore above error if any.
[ 2.272185] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 2.272189] [drm] No driver support for vblank timestamp query.
[ 2.272278] [drm] Screen objects system initialized
[ 2.272331] [drm] width 1920
[ 2.272346] [drm] height 1080
[ 2.272354] [drm] bpp 32
[ 2.277202] [drm] Fifo max 0x00200000 min 0x00001000 cap 0x0000077f
[ 2.287233] fb: conflicting fb hw usage svgadrmfb vs VESA VGA - removing generic driver
[ 2.287724] fbcon: svgadrmfb (fb0) is primary device
[ 2.319157] [drm] Initialized vmwgfx 2.4.0 20120209 for 0000:00:0f.0 on minor 0
TagsNo tags attached.
abrt_hash
URL

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-08-23 16:00 jfriedrich New Issue