View Issue Details

IDProjectCategoryView StatusLast Update
0007568CentOS-6nss-pam-ldapdpublic2018-07-08 19:39
Reporterbiohazd 
PriorityhighSeverityblockReproducibilityalways
Status newResolutionopen 
Product Version6.5 
Target VersionFixed in Version 
Summary0007568: cant install nss-pam-ldap as it says the glibc version is too high
DescriptionCan't install "nss-pam-ldap" as it says the glibc version is too high

The error seems to be :
Requires: glibc-common = 2.12-1.132.el6_5.3
Installed: glibc-common-2.12-1.132.el6_5.4.x86_64

root@me2 ~ # rpm -qa | grep glibc
glibc-headers-2.12-1.132.el6_5.4.x86_64
glibc-common-2.12-1.132.el6_5.4.x86_64
glibc-devel-2.12-1.132.el6_5.4.x86_64
glibc-2.12-1.132.el6_5.4.x86_64
Steps To Reproducebase install of CentOS 6.5 -(64bit), then fully patched (yum upgrade). Then try install "nss-pam-ldap.

root@me2 ~ # yum install nss-pam-ldapd
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * epel: epel.check-update.co.uk
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package nss-pam-ldapd.x86_64 0:0.7.5-18.2.el6_4 will be installed
--> Processing Dependency: nscd for package: nss-pam-ldapd-0.7.5-18.2.el6_4.x86_64
--> Processing Dependency: /lib64/security/pam_ldap.so for package: nss-pam-ldapd-0.7.5-18.2.el6_4.x86_64
--> Running transaction check
---> Package nscd.x86_64 0:2.12-1.132.el6_5.3 will be installed
--> Processing Dependency: glibc = 2.12-1.132.el6_5.3 for package: nscd-2.12-1.132.el6_5.3.x86_64
---> Package pam_ldap.x86_64 0:185-11.el6 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6_5.3 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6_5.3 for package: glibc-2.12-1.132.el6_5.3.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6_5.3.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6_5.3.i686
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6_5.3 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6_5.3 for package: glibc-2.12-1.132.el6_5.3.i686
---> Package nss-softokn-freebl.i686 0:3.14.3-10.el6_5 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.132.el6_5.3.i686 (centos-updates)
           Requires: glibc-common = 2.12-1.132.el6_5.3
           Installed: glibc-common-2.12-1.132.el6_5.4.x86_64 (@updates)
               glibc-common = 2.12-1.132.el6_5.4
           Available: glibc-common-2.12-1.132.el6.x86_64 (centos-base)
               glibc-common = 2.12-1.132.el6
           Available: glibc-common-2.12-1.132.el6_5.1.x86_64 (centos-updates)
               glibc-common = 2.12-1.132.el6_5.1
           Available: glibc-common-2.12-1.132.el6_5.2.x86_64 (centos-updates)
               glibc-common = 2.12-1.132.el6_5.2
           Available: glibc-common-2.12-1.132.el6_5.3.x86_64 (centos-updates)
               glibc-common = 2.12-1.132.el6_5.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
TagsNo tags attached.

Activities

gfrankliu

gfrankliu

2018-07-06 22:24

reporter   ~0032187

fully patched (yum upgrade) would bring centos 6.5 to 6.10, which will have glibc-2.12-1.212.el6.x86_64

I think something wrong with your setup.
kathenas

kathenas

2018-07-08 16:44

reporter   ~0032200

@biohazd

Cannot reproduce and an install of that application from 6.5 is working and pulling in correct deps.

Can you attach a file with the out of:

yum list installed > yum_installed.txt

and lets see if anything pops out, if anything.
biohazd

biohazd

2018-07-08 19:39

reporter   ~0032201

this was 2014 - please close it now.

Issue History

Date Modified Username Field Change
2014-09-05 10:01 biohazd New Issue
2018-07-06 22:24 gfrankliu Note Added: 0032187
2018-07-08 16:44 kathenas Note Added: 0032200
2018-07-08 19:39 biohazd Note Added: 0032201