View Issue Details

IDProjectCategoryView StatusLast Update
0007611CentOS-7xfsprogspublic2015-03-29 18:48
Reportersmbrannon 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version7.0-1406 
Target VersionFixed in Version 
Summary0007611: man pages for xfsprogs components still refer to the deprecated xfs_check
Descriptionman pages for xfsprogs components still refer to the deprecated xfs_check.
Steps To Reproduceman xfs_db
man xfs_repair
Additional Informationman pages for xfsprogs components still refer to the deprecated xfs_check


Version-Release number of selected component (if applicable):

xfsprogs-3.2.0-0.10.alpha2.el7.x86_64 from CentOS 7

How reproducible:

Always

 
Steps to Reproduce:

man xfs_db
man xfs_repair

Actual results:

xfs_db man page mentions xfs_check throughout.
xfs_repair includes xfs_check in the "See also:" section.


Expected results:

xfs_repair: State that xfs_repair has completely replaced xfs_check.
xfs_db: Reword man page to refer to xfs_repair instead of xfs_check.
Tags7.1-QA
abrt_hash
URL

Activities

TrevorH

TrevorH

2014-09-19 13:47

manager   ~0020949

This would need to be reported upstream on bugzilla.redhat.com for a fix since CentOS only repackages what RH provide. If you have a bugzilla entry then you can cross link the CentOS and Redhat bug entries.
smbrannon

smbrannon

2014-09-21 02:54

reporter   ~0020968

Already did that, just didn't know for sure to whom I should send these types of bugs.

Red Hat bug: Bug 1144208

Surprisingly it was closed less than seven minutes after I submitted it:

Eric Sandeen 2014-09-18 22:49:27 EDT
commit bfc541e77b9af46a2e3764df595620ec9824a456
Author: Eric Sandeen <sandeen@redhat.com>
Date: Tue May 20 18:30:23 2014 +1000

    xfsprogs: remove xfs_check
    
    This removes xfs_check and all references to it in
    manpages. The DIAGNOSTICS section from xfs_check(8)
    has been moved to xfs_db(8).
    
    Signed-off-by: Eric Sandeen <sandeen@redhat.com>
    Reviewed-by: Dave Chinner <dchinner@redhat.com>
    Signed-off-by: Dave Chinner <david@fromorbit.com>

$ git show bfc541e77b9af46a2e3764df595620ec9824a456 | lsdiff
a/db/Makefile
a/db/xfs_check.sh
a/man/man8/xfs_check.8
a/man/man8/xfs_db.8
a/man/man8/xfs_mdrestore.8
a/man/man8/xfs_ncheck.8
a/man/man8/xfs_repair.8


fixed this, and is in xfsprogs-3.2.1. So this is already fixed for RHEL7.1.

(xfs_db does still implement check internally, so some references to that functionality remain)

Thanks
-Eric
Status: NEW ? CLOSED
Resolution: --- ? NEXTRELEASE
Last Closed: 2014-09-18 22:49:27
tigalch

tigalch

2015-03-29 18:48

manager   ~0022617

Fixed with 7.1 or the 7.0-CR packages.

Issue History

Date Modified Username Field Change
2014-09-19 03:00 smbrannon New Issue
2014-09-19 13:47 TrevorH Note Added: 0020949
2014-09-21 02:54 smbrannon Note Added: 0020968
2014-09-21 10:12 tigalch Tag Attached: 7.1-QA
2015-03-29 18:48 tigalch Note Added: 0022617
2015-03-29 18:48 tigalch Status new => resolved
2015-03-29 18:48 tigalch Resolution open => fixed