View Issue Details

IDProjectCategoryView StatusLast Update
0007657CentOS-7pacemakerpublic2014-10-10 19:26
Reportervacosta Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Platform3.10.0-123.8.1.el7.x86_64OSCentOSOS Version7
Product Version7.0-1406 
Fixed in Version7.0-1406 
Summary0007657: Pacemaker Cluster make kernel crash
DescriptionWe are trying pacemaker with pcs and corosync and everything works done but when we create 2 fencing devices (fence_vmware_soap) and enable stonith, our cluster start having many troubles, like:
- Timeout when i try to list cluster property
- Standby/Unstandby doesn't work
- Everything down in the pcs webtool, and very very slow web tool
Additional Information:[System Logs]:
:ago 04 23:20:15 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:20:15 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1abe8e0
:ago 04 23:20:15 asusisv-pm2 crmd[17893]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:20:38 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:20:38 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1b0cd80
:ago 04 23:20:38 asusisv-pm2 crmd[18094]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:21:00 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:21:00 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1abe8e0
:ago 04 23:21:00 asusisv-pm2 crmd[18279]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:21:23 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:21:23 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1b0cd80
:ago 04 23:21:23 asusisv-pm2 crmd[18407]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:21:46 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:21:46 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1abe8e0
:ago 04 23:21:46 asusisv-pm2 crmd[18562]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:21:47 asusisv-pm2 lrmd[1502]: warning: qb_ipcs_event_sendv: new_event_notification (1502-18562-7): Broken pipe (32)
:ago 04 23:21:47 asusisv-pm2 lrmd[1502]: warning: send_client_notify: Notification of client crmd/03892bc2-def1-4caa-827f-e8ee1ccf64b8 failed
:ago 04 23:22:09 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:22:09 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1b297c0
:ago 04 23:22:22 asusisv-pm2 crmd[18692]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:22:22 asusisv-pm2 lrmd[1502]: warning: qb_ipcs_event_sendv: new_event_notification (1502-18692-8): Broken pipe (32)
:ago 04 23:22:22 asusisv-pm2 lrmd[1502]: warning: send_client_notify: Notification of client crmd/e311a88d-8850-4d0f-89e4-e601238538ce failed
:ago 04 23:22:22 asusisv-pm2 lrmd[1502]: warning: send_client_notify: Notification of client crmd/e311a88d-8850-4d0f-89e4-e601238538ce failed
:ago 04 23:22:44 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:22:44 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1b38810
:ago 04 23:22:44 asusisv-pm2 crmd[19012]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:22:44 asusisv-pm2 lrmd[1502]: warning: qb_ipcs_event_sendv: new_event_notification (1502-19012-7): Bad file descriptor (9)
:ago 04 23:22:44 asusisv-pm2 lrmd[1502]: warning: send_client_notify: Notification of client crmd/35ba574e-24b3-4578-a7dd-bd1ad0d703ea failed
:ago 04 23:23:07 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:23:07 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1b38810
:ago 04 23:23:39 asusisv-pm2 crmd[19156]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:23:39 asusisv-pm2 lrmd[1502]: warning: qb_ipcs_event_sendv: new_event_notification (1502-19156-7): Bad file descriptor (9)
:ago 04 23:23:39 asusisv-pm2 lrmd[1502]: warning: send_client_notify: Notification of client crmd/523572fa-c135-480f-abd3-46389dfc8184 failed
:ago 04 23:24:01 asusisv-pm2 lrmd[1502]: error: crm_abort: lrmd_ipc_dispatch: Triggered assert at main.c:116 : flags & crm_ipc_client_response
:ago 04 23:24:01 asusisv-pm2 lrmd[1502]: error: lrmd_ipc_dispatch: Invalid client request: 0x1b38810
:ago 04 23:24:02 asusisv-pm2 crmd[19649]: warning: do_update_resource: Resource asusisv-pm2 no longer exists in the lrmd
:ago 04 23:24:02 asusisv-pm2 lrmd[1502]: warning: qb_ipcs_event_sendv: new_event_notification (1502-19649-7): Bad file descriptor (9)
TagsNo tags attached.
abrt_hash
URL

Activities

vacosta

vacosta

2014-10-10 19:25

reporter   ~0021121

Now with the last release of pacemaker
[root@asusisv-pm1 ~]# rpm -qi pacemaker
Name : pacemaker
Version : 1.1.10
Release : 32.el7_0.1
Architecture: x86_64
Install Date: lun 06 oct 2014 10:04:28 PYST
We see the problem was resolved.
tigalch

tigalch

2014-10-10 19:26

manager   ~0021122

Marking as SOLVED per reporters feedback

Issue History

Date Modified Username Field Change
2014-10-01 15:26 vacosta New Issue
2014-10-10 19:25 vacosta Note Added: 0021121
2014-10-10 19:26 tigalch Note Added: 0021122
2014-10-10 19:26 tigalch Status new => resolved
2014-10-10 19:26 tigalch Fixed in Version => 7.0-1406
2014-10-10 19:26 tigalch Resolution open => fixed
2014-10-20 12:14 shengvvvvv Issue cloned: 0007720