View Issue Details

IDProjectCategoryView StatusLast Update
0007777CentOS-7postfixpublic2014-10-25 15:54
ReporterCentzilius Assigned To 
PriorityhighSeverityblockReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version7.0-1406 
Summary0007777: postfix doesn't start up
DescriptionIt began when I updated my postfix config and wanted to restart my postfix daemon with systemctl restart postfix. It complained about not finding /usr/bin/postfix which were located at /usr/sbin/postfix.
I reinstalled the package with yum reinstall postfix.
I tried to restart postfix and got an error from systemd. systemctl status postfix gave me the following log: See file 1.
I tried to workaround this by creating a symlink from /usr/libexec/postfix to /usr/lib/postfix and got the following error: See file 2.
Steps To ReproduceStart Postfix
TagsNo tags attached.
abrt_hash
URL

Activities

Centzilius

Centzilius

2014-10-22 16:11

reporter  

postfix-error-1.txt (951 bytes)   
postfix.service - Postfix Mail Transport Agent
   Loaded: loaded (/usr/lib/systemd/system/postfix.service; enabled)
   Active: failed (Result: exit-code) since Wed 2014-10-22 18:07:26 CEST; 5s ago
  Process: 23745 ExecStart=/usr/sbin/postfix start (code=exited, status=1/FAILURE)
  Process: 23742 ExecStartPre=/usr/libexec/postfix/chroot-update (code=exited, status=0/SUCCESS)
  Process: 23736 ExecStartPre=/usr/libexec/postfix/aliasesdb (code=exited, status=0/SUCCESS)
 Main PID: 2269 (code=killed, signal=TERM)

Oct 22 18:07:25 naira systemd[1]: Starting Postfix Mail Transport Agent...
Oct 22 18:07:25 naira postfix[23745]: fatal: chdir(/usr/lib/postfix): No such file or directory
Oct 22 18:07:26 naira systemd[1]: postfix.service: control process exited, code=exited status=1
Oct 22 18:07:26 naira systemd[1]: Failed to start Postfix Mail Transport Agent.
Oct 22 18:07:26 naira systemd[1]: Unit postfix.service entered failed state.
postfix-error-1.txt (951 bytes)   
Centzilius

Centzilius

2014-10-22 16:11

reporter  

postfix-error-2.txt (1,029 bytes)   
postfix.service - Postfix Mail Transport Agent
   Loaded: loaded (/usr/lib/systemd/system/postfix.service; enabled)
   Active: failed (Result: exit-code) since Wed 2014-10-22 18:10:54 CEST; 1s ago
  Process: 23933 ExecStart=/usr/sbin/postfix start (code=exited, status=1/FAILURE)
  Process: 23931 ExecStartPre=/usr/libexec/postfix/chroot-update (code=exited, status=0/SUCCESS)
  Process: 23926 ExecStartPre=/usr/libexec/postfix/aliasesdb (code=exited, status=0/SUCCESS)
 Main PID: 2269 (code=killed, signal=TERM)

Oct 22 18:10:54 naira postfix[23933]: /usr/lib/postfix/postfix-script: line 71: /usr/bin/postconf: No such file or directory
Oct 22 18:10:54 naira postfix[23933]: /usr/lib/postfix/postfix-script: line 72: /usr/bin/postlog: No such file or directory
Oct 22 18:10:54 naira systemd[1]: postfix.service: control process exited, code=exited status=1
Oct 22 18:10:54 naira systemd[1]: Failed to start Postfix Mail Transport Agent.
Oct 22 18:10:54 naira systemd[1]: Unit postfix.service entered failed state.
postfix-error-2.txt (1,029 bytes)   
Evolution

Evolution

2014-10-22 16:32

reporter   ~0021360

This sounds like a configuration issue. Creating random symlinks likely not the best fix.

With the default package and no config modifications I am able to start, stop and restart postfix just fine. I suspect you need to edit your config.
Centzilius

Centzilius

2014-10-22 17:30

reporter   ~0021361

Thanks for the help... I forgot to check the configuration file for possible solutions.
tigalch

tigalch

2014-10-23 18:32

manager   ~0021368

Is this fixed?
Centzilius

Centzilius

2014-10-23 19:45

reporter   ~0021372

yes it is
tigalch

tigalch

2014-10-25 15:54

manager   ~0021390

Marking as solved per reporters feedback

Issue History

Date Modified Username Field Change
2014-10-22 16:11 Centzilius New Issue
2014-10-22 16:11 Centzilius File Added: postfix-error-1.txt
2014-10-22 16:11 Centzilius File Added: postfix-error-2.txt
2014-10-22 16:32 Evolution Note Added: 0021360
2014-10-22 17:30 Centzilius Note Added: 0021361
2014-10-23 18:32 tigalch Note Added: 0021368
2014-10-23 18:32 tigalch Status new => feedback
2014-10-23 19:45 Centzilius Note Added: 0021372
2014-10-23 19:45 Centzilius Status feedback => assigned
2014-10-25 15:54 tigalch Note Added: 0021390
2014-10-25 15:54 tigalch Status assigned => resolved
2014-10-25 15:54 tigalch Resolution open => no change required