View Issue Details

IDProjectCategoryView StatusLast Update
0007822CentOS-6-OTHERpublic2015-08-08 10:31
Reporterdkozei 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.6 
Target VersionFixed in Version6.7 
Summary0007822: NX client session can not be started
DescriptionAfter successful system upgrade to CentOS 6.6 with "yum upgrade" NX (nx-3.5.0-2.1.el6.centos.x86_64 package) client session can not be started. Previously working version seemed to be CentOS 6.4 (not 6.5)

Log message:
/usr/lib/NX/nxagent: symbol lookup error: /usr/lib64/libXfixes.so.3: undefined symbol: _XGetRequest

** (gnome-session:7074): WARNING **: Cannot open display:

Package versions
nx-3.5.0-2.1.el6.centos.x86_64
libXfixes-5.0.1-2.1.el6.x86_64
libX11-1.6.0-2.2.el6.x86_64

I'm not good with all that linking stuff but as found something to provide in https://bugzilla.redhat.com/show_bug.cgi?id=782251 I'll provide some outputs for reference:
# nm -D /usr/lib64/libXfixes.so.3|grep _XGetRequest
                 U _XGetRequest
# nm -D /usr/lib64/libX11.so.6|grep _XGetRequest
0000000000043eb0 T _XGetRequest
# ldd -r -d /usr/lib64/libXfixes.so.3
        linux-vdso.so.1 => (0x00007fff8c9ff000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f9dc0746000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f9dc03b2000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f9dc0193000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f9dbff8f000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f9dc0c98000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f9dbfd8c000)
#ldd -r -d /usr/lib64/libX11.so.6
        linux-vdso.so.1 => (0x00007fff91fff000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f51330c8000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f5132ec4000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f5132b2f000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f513292c000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f5133633000)
Steps To Reproduceupgrade the system with "yum upgrade". Try to connect to nx server.
TagsNo tags attached.

Activities

tigalch

tigalch

2014-11-03 18:06

manager   ~0021526

I only tried using 6.6, nx and x2go-server from EPEL. This combination still worked fine after the update from 6.5 to 6.6. I'll check my lib versions tomorrow and post here.
kapet3

kapet3

2014-11-04 14:01

reporter   ~0021539

I have got similar problems after an upgrade from 6.5 to 6.6, the following helped me, provisionally.

 yum --releasever=6.5 downgrade libXfixes
tigalch

tigalch

2014-11-04 14:04

manager   ~0021540

Here are my libs:
nx-libs-3.5.0.27-1.el6.i686
nxagent-3.5.0.27-1.el6.i686
libXfixes-5.0.1-2.1.el6.i686
libX11-1.6.0-2.2.el6.i686
dkozei

dkozei

2014-11-06 10:31

reporter   ~0021564

Upgrading the system with "yum -x libXfixes upgrade" makes it work for me. As there is no updates for nx package during upgrade from 6.4 to 6.6 I assume either nx should be recompiled or libXfixes should be fixed.

Currently installed and working libXfixes
Name : libXfixes
Arch : x86_64
Version : 5.0
Release : 3.el6

not working but suggested by yum:
Name : libXfixes
Arch : x86_64
Version : 5.0.1
Release : 2.1.el6
tigalch

tigalch

2014-11-06 17:37

manager   ~0021570

Should we consider this solved then?
kapet3

kapet3

2014-11-07 17:19

reporter   ~0021599

I don't think it is solved. Only a workaround based on not upgrading libXfixes is presented here. As proposed by dkozei, I think that nx package should be recompiled or somehow fixed to reflect changes in libXfixes library (supposing it is not a bug in libXfixes itself).
eli

eli

2014-11-13 08:17

reporter   ~0021659

I seem to be having the same problem. Only I checked and I only have the problem with the OS X client. The old Windows 3.5 client seems to work OK. I was wondering if that was true in general or not.

I also could not get it to work using "yum -x libXfixes upgrade". When I run that, I get "No Packages marked for Update"

I am running Centos 6.6 and this behavior started after I upgraded from 6.5. I also could not figure out how to successfully roll back the 6.6 version of libX.

Thanks.
eli

eli

2014-11-13 08:33

reporter   ~0021660

Update. I got 'yum --releasever=6.5 downgrade libXfixes libXfixes-devel' to work and now my OS X version of the NX client works, so there is something funky going on with version 6.6 of those files.
kostas

kostas

2014-11-15 21:09

reporter   ~0021713

Hi
It seems that I have exactly the same problem but cannot get 'yum --releasever=6.5 downgrade libXfixes libXfixes-devel' to work as eli suggested.

When issue I get

Loaded plugins: changelog, fastestmirror, priorities, protectbase, refresh-packagekit, security
Setting up Downgrade Process
Loading mirror speeds from cached hostfile
 * base: merlin.fit.vutbr.cz
 * centosplus: merlin.fit.vutbr.cz
 * elrepo: ftp.nluug.nl
 * extras: merlin.fit.vutbr.cz
 * rpmforge: merlin.fit.vutbr.cz
 * updates: merlin.fit.vutbr.cz
http://centos.karan.org/el6.5/extras/stable/x86_64/RPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: kbs-CentOS-Extras. Please verify its path and try again

I would appreciate if you could help to downgrade the libXfixes and get nx back to work.
Thank you very much in advance.
kostas

kostas

2014-11-17 11:39

reporter   ~0021718

I manage to downgrade the libXfixes libraries to 5.0-3.el6 and could open the X-window but I get a black screen, I don't see the desktop, and I can only close it.

I remove nx freenx and reinstall them.

X-window lunches but still black screen.

Has anyone observed the same behavior? Any workaround?

Thanks
JohnnyHughes

JohnnyHughes

2014-11-19 12:14

administrator   ~0021735

I am going to rebuild our NX and see if that helps. Our NX is based on the latest code that was released by nomachine for their 3.5 branch, so you can still use it if you like.

But EPEL is now releasing software from the x2go Project, and they have fixed bugs and issues now that nomachine has moved on to their 4.x code.

I would recommend removing freenx / nx and using x2go instead.
JohnnyHughes

JohnnyHughes

2014-11-19 12:36

administrator   ~0021736

Please test these packages and provide feedback:

http://people.centos.org/hughesjr/nx-test/
saerom

saerom

2014-11-19 13:19

reporter   ~0021737

Runned rpm upgrade using your package:
Installed Packages
nx.x86_64 3.5.0-2.2.el6.centos installed

Unfortunately it seems not solve it. Still got the error:
/usr/lib/NX/nxagent: symbol lookup error: /usr/lib64/libXfixes.so.3: undefined symbol: _XGetRequest
toracat

toracat

2014-11-19 22:12

manager   ~0021745

To people who are seeing the issue,

- Do you have nx-libs installed?
- what do you have in /usr/lib64/nx/
- Can you try and see if the nx package from nux-dextop repository [1] works?

[1] http://li.nux.ro/download/nux/dextop/el6/x86_64/
claudio

claudio

2014-11-26 13:56

reporter   ~0021809

..on CentOS 6.6 x64 with freenx-0.7.3-9.4.el6.centos.x86_64

Just

# yum install epel-release
# yum update


--
Claudio
dkozei

dkozei

2014-11-26 14:06

reporter   ~0021810

Hello,

toracat

1) we do not have nx-libs package in base repo as I can see, but there is one in EPEL:

yum search nx-libs
Loaded plugins: dellsysid, fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * extras: mirror.millry.co
 * updates: mirror.cogentco.com
base | 3.7 kB 00:00
dell-omsa-indep | 1.9 kB 00:00
dell-omsa-specific | 1.9 kB 00:00
extras | 3.4 kB 00:00
updates | 3.4 kB 00:00
Warning: No matches found for: nx-libs
No Matches found

2) Please see the output (we have NX not nx in lib64):

$ ls -l /usr/lib64/NX/*
-rwxr-xr-x. 1 root root 4655536 Oct 19 2012 /usr/lib64/NX/nxagent
-rwxr-xr-x. 1 root root 5128 Oct 19 2012 /usr/lib64/NX/nxproxy
-rwxr-xr-x. 1 root root 343272 Oct 19 2012 /usr/lib64/NX/nxssh

/usr/lib64/NX/lib:
total 2124
lrwxrwxrwx. 1 root root 13 Feb 16 2013 libX11.so.6 -> libX11.so.6.2
-rwxr-xr-x. 1 root root 960296 Oct 19 2012 libX11.so.6.2
lrwxrwxrwx. 1 root root 20 Feb 16 2013 libXcompext.so.3 -> libXcompext.so.3.5.0
-rwxr-xr-x. 1 root root 62128 Oct 19 2012 libXcompext.so.3.5.0
lrwxrwxrwx. 1 root root 21 Feb 16 2013 libXcompshad.so.3 -> libXcompshad.so.3.5.0
-rwxr-xr-x. 1 root root 45040 Oct 19 2012 libXcompshad.so.3.5.0
lrwxrwxrwx. 1 root root 17 Feb 16 2013 libXcomp.so.3 -> libXcomp.so.3.5.0
-rwxr-xr-x. 1 root root 986032 Oct 19 2012 libXcomp.so.3.5.0
lrwxrwxrwx. 1 root root 14 Feb 16 2013 libXext.so.6 -> libXext.so.6.4
-rwxr-xr-x. 1 root root 70656 Oct 19 2012 libXext.so.6.4
lrwxrwxrwx. 1 root root 19 Feb 16 2013 libXrender.so.1 -> libXrender.so.1.2.2
-rwxr-xr-x. 1 root root 40864 Oct 19 2012 libXrender.so.1.2.2

3) unfortunately I personally can not try installing anything right now. May be someone would be faster. If not I'll try it half a month later.
pschoond

pschoond

2014-12-12 12:45

reporter   ~0021916

Hello,

Experienced the exact same problem, connecting with Nomachine nx client from Kubuntu desktop. Windows client still appears to connect ok (?!).
Just today did a upgrade of nx via yum update to version nx-3.5.0-2.2.el6.centos.x86_64, but still the same problem.
The downgrade to libXfixes-5.0.1-2.1.el6.x86_64 (described above) solved it for now.
Something 's gone missing in the latest version of libXfixes.

regards,

Paul S
pschoond

pschoond

2014-12-12 12:46

reporter   ~0021917

Sorry, that should read 'The downgrade to libXfixes-5.0-3.el6.x86_64.."

Paul S
ecdowney

ecdowney

2015-01-08 07:04

reporter   ~0022089

yum uprade tonight from 6.5 to 6.6 and found this issue. Tried the ideas presented here, no luck. Any progress? Thanks.
dkozei

dkozei

2015-01-19 13:56

reporter   ~0022164

Installing epel-release and updating the system fixes the issue for me:

# yum install epel-release
# yum update

Part of update output:
Installing:
 nx-libs x86_64 3.5.0.27-1.el6 epel 18 k
     replacing nx.x86_64 3.5.0-2.2.el6.centos
 nxagent x86_64 3.5.0.27-1.el6 epel 1.5 M
     replacing nx.x86_64 3.5.0-2.2.el6.centos
 nxproxy x86_64 3.5.0.27-1.el6 epel 8.8 k
     replacing nx.x86_64 3.5.0-2.2.el6.centos
Installing for dependencies:
 libNX_X11 x86_64 3.5.0.27-1.el6 epel 499 k
 libNX_Xcomposite x86_64 3.5.0.27-1.el6 epel 9.7 k
 libNX_Xdamage x86_64 3.5.0.27-1.el6 epel 9.6 k
 libNX_Xdmcp x86_64 3.5.0.27-1.el6 epel 14 k
 libNX_Xext x86_64 3.5.0.27-1.el6 epel 28 k
 libNX_Xfixes x86_64 3.5.0.27-1.el6 epel 13 k
 libNX_Xinerama x86_64 3.5.0.27-1.el6 epel 10 k
 libNX_Xpm x86_64 3.5.0.27-1.el6 epel 37 k
 libNX_Xrandr x86_64 3.5.0.27-1.el6 epel 12 k
 libNX_Xrender x86_64 3.5.0.27-1.el6 epel 22 k
 libNX_Xtst x86_64 3.5.0.27-1.el6 epel 15 k
 libXcomp x86_64 3.5.0.27-1.el6 epel 306 k
 libXcompext x86_64 3.5.0.27-1.el6 epel 36 k
 libXcompshad x86_64 3.5.0.27-1.el6 epel 34 k
JohnnyHughes

JohnnyHughes

2015-08-08 10:31

administrator   ~0023812

we have removed nx, freenx, opennx from CentOS Extras .. now only available via EPEL.

Issue History

Date Modified Username Field Change
2014-11-03 16:30 dkozei New Issue
2014-11-03 18:06 tigalch Note Added: 0021526
2014-11-04 14:01 kapet3 Note Added: 0021539
2014-11-04 14:04 tigalch Note Added: 0021540
2014-11-06 10:31 dkozei Note Added: 0021564
2014-11-06 17:37 tigalch Note Added: 0021570
2014-11-07 17:19 kapet3 Note Added: 0021599
2014-11-13 08:17 eli Note Added: 0021659
2014-11-13 08:33 eli Note Added: 0021660
2014-11-15 21:09 kostas Note Added: 0021713
2014-11-17 11:39 kostas Note Added: 0021718
2014-11-19 12:14 JohnnyHughes Note Added: 0021735
2014-11-19 12:36 JohnnyHughes Note Added: 0021736
2014-11-19 12:36 JohnnyHughes Status new => feedback
2014-11-19 13:19 saerom Note Added: 0021737
2014-11-19 22:12 toracat Note Added: 0021745
2014-11-26 13:56 claudio Note Added: 0021809
2014-11-26 14:06 dkozei Note Added: 0021810
2014-11-26 14:06 dkozei Status feedback => assigned
2014-12-12 12:45 pschoond Note Added: 0021916
2014-12-12 12:46 pschoond Note Added: 0021917
2015-01-08 07:04 ecdowney Note Added: 0022089
2015-01-19 13:56 dkozei Note Added: 0022164
2015-08-08 10:31 JohnnyHughes Note Added: 0023812
2015-08-08 10:31 JohnnyHughes Status assigned => resolved
2015-08-08 10:31 JohnnyHughes Fixed in Version => 6.7
2015-08-08 10:31 JohnnyHughes Resolution open => fixed