2017-06-27 05:10 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0007827CentOS-6kernelpublic2017-03-12 06:10
ReporterSuperDaveAU 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
Platformx86_64OSCentosOS Version6.6
Product Version6.6 
Target VersionFixed in Version 
Summary0007827: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
DescriptionAfter updating the kernel to 2.6.32-504.el6.x86_64 using yum update, I reboot using the new kernel and get a kernel panic with the below error:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Pid: 1, comm: swapper Not tainted 2.6.32-502.el6.x86_64 #1
Call Trace:
 [<ffffffff815292bc>] ? panic+0xa7/0x16f
 [<ffffffff81c2b432>] ? mount_block_root+0x216/0x2cb
 [<ffffffff81002930>] ? bstat+0x2b0/0x980
 [<ffffffff81c2b53d>] ? mount_root+0x56/0x5a
 [<ffffffff81c2b6b1>] ? prepare_namespace+0x170/0x1a9
 [<ffffffff81c2a92a>] ? kernel_init+0x2e1/0x2f7
 [<ffffffff8100c20a>] ? child_rip+0xa/0x20
 [<ffffffff81c2a649>] ? kernel_init+0x0/0x2f7
 [<ffffffff8100c200>] ? child_rip+0x0/0x20

Steps To Reproduceupdate kernel to 2.6.32-504.el6.x86_64 and reboot
Additional InformationThis is a centos 6.6 KVM virtualmachine running on a centos 6.5 KVM server running:

CentOS release 6.5 (Final)
Linux vmmanager.test.com 2.6.32-431.el6.x86_64 #1 SMP Fri Nov 22 03:15:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
libvirt-client-0.10.2-29.el6_5.8.x86_64
virt-what-1.11-1.2.el6.x86_64
virt-manager-0.9.0-19.el6.x86_64
python-virtinst-0.600.0-18.el6.noarch
libvirt-0.10.2-29.el6_5.8.x86_64
libvirt-python-0.10.2-29.el6_5.8.x86_64
qemu-kvm-0.12.1.2-2.415.el6_5.8.x86_64
Tagsyum
Attached Files

-Relationships
related to 0006310assignedtoracat missing initramfs: kernel panic - not syncing: VFS: Unable to mount root partition after yum update. 
+Relationships

-Notes

~0021535

juanvalino (reporter)

I had the same problem after an upgrade to CentOS 6.6 from version 6.5 on a
physical blade server.

After investigating I discovered that initramfs, modules.dep and other config
items associated to the kernel were missing.

I think that the transaction during the update of the kernel was incomplete in
some way.

To solve the problem I booted in the old kernel and made a "yum reinstall" of
all the new kernel packages.

~0021536

SuperDaveAU (reporter)

I can also confirm that after running a 'yum reinstall kernel' and rebooting this fixed my issue.

~0021537

SuperDaveAU (reporter)

This is more of a workaround though.
Do we know why it broke?

~0021584

daveginorge (reporter)

On 2 of my systems I had to run yum-complete-transaction to finish the update/upgrade, both times 351 items not completed. Afterwards a removal and re-installation of the kernel solved the problem.

~0021588

JohnnyHughes (administrator)

for whatever the reason, your building the initrd image did not work .. not sure why that would break. But obviously it does not break every time.

~0021598

timj (reporter)

I had this problem too, but as juanvalino reported, I also found it was due to a failed yum transaction, resulting in the post-install scripts for the kernel package not being run, and therefore various things including initramfs, modules.dep being missing.

Removing the kernel package and installing again solved the problem.

It's not clear to me what caused the failure, but it is not obviously related specifically to the kernel package update, so I am going to mark it down as a random failure. On another essentially identical machine, installing the kernel update (only) worked fine, as did installing the remainder of the CentOS 6.6 update.

~0022256

pakeZonite (reporter)

I have the same issue, but removing and reinstalling the kernel did not solve the problem for me.

I'm running CentOS in a RHEV VM (KVM).

Booting with the old kernel still works.

~0024726

slobastev (reporter)

I had the same problem.

During a startup, I pressed ESC to stop the boot.

It gave me a list of available kernels. I choose the second newest.
After I had logged in, I used the following commands to list all available kernels

command:

rpm -qa kernel

my output:

kernel-2.6.32-504.23.4.el6.x86_64
kernel-2.6.32-573.3.1.el6.x86_64
kernel-2.6.32-573.7.1.el6.x86_64
kernel-2.6.32-504.30.3.el6.x86_64
kernel-2.6.32-573.1.1.el6.x86_64

I used the command to see the current kernel

uname -r

my newest one was kernel-2.6.32-573.7.1.el6.x86_64

To delete that kernel I issued a command

sudo yum remove kernel-2.6.32-573.7.1.el6.x86_64

then to download the newest kernel again I run

sudo yum update

After the restart (sudo shutdown -r 0) the computer booted with the newest kernel without any problems.

~0024728

toracat (manager)

This problem occurs from time to time. Please follow https://bugs.centos.org/view.php?id=6310 that handles the case.
+Notes

-Issue History
Date Modified Username Field Change
2014-11-04 10:43 SuperDaveAU New Issue
2014-11-04 12:34 juanvalino Note Added: 0021535
2014-11-04 13:13 SuperDaveAU Note Added: 0021536
2014-11-04 13:14 SuperDaveAU Note Added: 0021537
2014-11-07 12:06 daveginorge Note Added: 0021584
2014-11-07 13:18 JohnnyHughes Note Added: 0021588
2014-11-07 16:34 timj Note Added: 0021598
2015-01-29 08:54 pakeZonite Note Added: 0022256
2015-10-28 22:16 slobastev Note Added: 0024726
2015-10-29 11:59 toracat Relationship added related to 0006310
2015-10-29 12:07 toracat Note Added: 0024728
2015-10-29 12:07 toracat Status new => closed
2015-10-29 12:07 toracat Resolution open => duplicate
2017-03-12 06:10 jition Tag Attached: yum
+Issue History