View Issue Details

IDProjectCategoryView StatusLast Update
0007972CentOS-6crashpublic2015-04-09 10:47
ReporterCentOS4Bill 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status newResolutionopen 
Product Version6.6 
Target VersionFixed in Version 
Summary0007972: Problem between getty/X on transition from runlevel 3 to 5 causes random crash of X, node "freeze", tty switch to fail
DescriptionX sessions start on tty1 while it appears code in the system expects tty7 (/etc/sysconfig/init last few lines)? This comes to light on transition from run level 3 to 5. Attempts to start additional X session from the first via System->Logout-Switch user cause various symptoms which include "freezes", X crashes, and inconsistent behavior regarding logging in to additional X sessions.

Symptoms may also include console switching to fail (e.g. <ctrl>-<alt>-<Fx> to switch to ttyx doesn't always work), sometimes "garbage" on screen of tty1 when any key is pressed (and a resulting inability to log in), etc. Gory details of all I tried are in

http://tinyurl.com/klsc2xj

All the files that I hoped would help, dmesg, messages, crash ccpp*/* files from four crashes (each different based on coredump sizes), etc are in

http://tinyurl.com/olbgv5q
Steps To ReproduceCombinations tried and results are in

http://tinyurl.com/klsc2xj
Additional InformationThese synptoms first appeared on a yum update from the CR repository. Subsequent updates did not fix the problem and I downloaded an install image to DVD and did a fresh install with no improvement seen.

From my limited background, I suspect that starting the first X session on tty1 (over which I have no control?) interferes somehow with the spawning of the gettys on the terminals as they keep dying at various times (see the messages file in the directory linked in "Description" of the problem.

If you must have files upload here, rather than in dropbox, please advise which ones - I've got more than a few available (see the linked directory contents up in "Description".

Any additional needed info, just let me know and I'll do my best,
TagsNo tags attached.

Activities

LiamOToole

LiamOToole

2015-04-08 14:43

reporter   ~0022710

I was bitten by this bug recently on a CentOS 6.6 desktop PC. I had switched run level from 5 to 3 and tried to switch back again. The result was that the VT prompt remained on screen and would not respond to keyboard input.

Fortunately I was able to connect via ssh from another machine and do a clean reboot. I noted several occurrences of the message "init: tty (/dev/tty1) main process ended, respawning" in /var/log/messages at around the time the system freeze happened.

I am surprised that a simple run level switch could have such a detrimental effect.

Issue History

Date Modified Username Field Change
2014-12-07 16:25 CentOS4Bill New Issue
2015-04-08 14:43 LiamOToole Note Added: 0022710