View Issue Details

IDProjectCategoryView StatusLast Update
0007975Buildsyscommunity buildsyspublic2014-12-15 16:07
Reporterapevec Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0007975: apevec: packager ACLs request for the Cloud SIG
DescriptionAs requested per ticket #0007955, I open up a ticket to gain access on CBS Koji on the behalf of the Fedora Cloud (approved by rbowen and kdas)

login: apevec
gpg public key: http://keys.fedoraproject.org/pks/lookup?search=0x92D6782228CD1B08F999F46802950054C6EEECA8
email: apevec@fedoraproject.org
SIG: Cloud SIG
TagsNo tags attached.

Activities

rbowen

rbowen

2014-12-08 17:16

reporter   ~0021882

+1 (From SIG member)
apevec

apevec

2014-12-14 21:48

reporter   ~0021948

I got tarball with CBS credentials but authentication against CBS fails:

 Error: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert handshake failure'), ('SSL routines', 'SSL3_WRITE_BYTES', 'ssl handshake failure')]
apevec

apevec

2014-12-15 13:04

reporter   ~0021956

As Haikel discovered, looks like we're both missing accounts in CBS Koji:
https://cbs.centos.org/koji/userinfo?userID=apevec returns

GenericError: query returned no rows
kbsingh@karan.org

kbsingh@karan.org

2014-12-15 13:42

reporter   ~0021958

w.r.t the connection issue, its down to SSLv3 not being allowed on cbs.centos.org anymore. ref: http://lists.centos.org/pipermail/centos-devel/2014-October/012126.html as a workaround if the koji client you have isnt fixed for this yet.
kbsingh@karan.org

kbsingh@karan.org

2014-12-15 13:42

reporter   ~0021959

w.r.t the user-id problem, this should also be fixed now.
apevec

apevec

2014-12-15 15:20

reporter   ~0021962

Confirmed, centos list-permissions --mine works now and returns "build" as expected.

First build is python-oslo-config which is at root of all openstack-* dep chains:
https://cbs.centos.org/koji/taskinfo?taskID=3687
arrfab

arrfab

2014-12-15 16:07

administrator   ~0021965

Link added on the dedicated wiki page, to include what to patch for the ssl/koji issue : http://wiki.centos.org/HowTos/CommunityBuildSystem

Issue History

Date Modified Username Field Change
2014-12-08 10:11 apevec New Issue
2014-12-08 17:16 rbowen Note Added: 0021882
2014-12-10 13:53 kbsingh@karan.org Project CentOS-7 => Buildsys
2014-12-10 13:53 kbsingh@karan.org Category -OTHER => general
2014-12-10 13:53 kbsingh@karan.org Category general => community buildsys
2014-12-10 13:56 kbsingh@karan.org Status new => acknowledged
2014-12-14 21:48 apevec Note Added: 0021948
2014-12-15 13:04 apevec Note Added: 0021956
2014-12-15 13:42 kbsingh@karan.org Note Added: 0021958
2014-12-15 13:42 kbsingh@karan.org Note Added: 0021959
2014-12-15 15:20 apevec Note Added: 0021962
2014-12-15 16:07 arrfab Note Added: 0021965
2014-12-15 16:07 arrfab Status acknowledged => resolved
2014-12-15 16:07 arrfab Resolution open => fixed