View Issue Details

IDProjectCategoryView StatusLast Update
0008121administrationoperationspublic2016-09-14 08:04
ReporterVictor Malov 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0008121: ip addr show up output shows IP addresses of down interfaces
Descriptionip addr show (look at eth7)

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:42:e9:3d:aa brd ff:ff:ff:ff:ff:ff
    inet 172.11.98.248/16 brd 172.11.255.255 scope global eth1
3: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc cbq state UP qlen 1000
    link/ether 00:1c:42:c6:d0:c4 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.242/19 brd 10.28.127.255 scope global eth2
4: eth4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:42:56:14:28 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.249/24 scope global eth4
5: eth3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:42:03:06:77 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.230/19 brd 10.28.127.255 scope global eth3
6: eth7: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:1c:42:4d:cb:d7 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.231/24 scope global eth7
    inet 192.168.13.0/18 scope global eth7
7: eth5: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:1c:42:81:0a:a4 brd ff:ff:ff:ff:ff:ff
8: eth6: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:1c:42:5c:12:40 brd ff:ff:ff:ff:ff:ff
9: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether b2:c1:df:b1:29:c7 brd ff:ff:ff:ff:ff:ff
    inet 10.47.130.2/24 brd 10.47.130.255 scope global br0
10: br1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 52:b4:3a:90:f2:05 brd ff:ff:ff:ff:ff:ff
11: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/void

ip addr show up

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:42:e9:3d:aa brd ff:ff:ff:ff:ff:ff
    inet 172.11.98.248/16 brd 172.11.255.255 scope global eth1
3: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc cbq state UP qlen 1000
    link/ether 00:1c:42:c6:d0:c4 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.242/19 brd 10.28.127.255 scope global eth2
4: eth4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:42:56:14:28 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.249/24 scope global eth4
5: eth3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:42:03:06:77 brd ff:ff:ff:ff:ff:ff
    inet 10.28.98.230/19 brd 10.28.127.255 scope global eth3
    inet 10.28.98.231/24 scope global eth7
    inet 192.168.13.0/18 scope global eth7
9: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether b2:c1:df:b1:29:c7 brd ff:ff:ff:ff:ff:ff
    inet 10.47.130.2/24 brd 10.47.130.255 scope global br0
10: br1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 52:b4:3a:90:f2:05 brd ff:ff:ff:ff:ff:ff
11: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/void

Note that 10.28.98.231, 192.168.13.0 has been set from eth7 to eth3 interface. It looks like not all output of down interfaces is dissapeared.
Steps To Reproduce1. Call ip addr show
2. Call ip addr show up
3. Compare difference of IP addresses.
TagsNo tags attached.

Activities

arrfab

arrfab

2016-09-14 08:04

administrator   ~0027502

bug triage : closing all bugs

Issue History

Date Modified Username Field Change
2015-01-23 11:05 Victor Malov New Issue
2016-09-14 08:04 arrfab Note Added: 0027502
2016-09-14 08:04 arrfab Status new => closed
2016-09-14 08:04 arrfab Resolution open => suspended