2017-06-28 15:51 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0008229CentOS-7gnome-shell-extensionspublic2015-04-30 12:30
Reporterbmurch 
PriorityurgentSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformLinuxOSCentOSOS Version7
Product Version7.0-1406 
Target VersionFixed in Version 
Summary0008229: gnome-shell-extension-apps-menu fails to launch applications
DescriptionA new install of CentOS 7 on 2 different machines both affected.
yum groupinstall "GNOME Desktop" "Graphical Administration Tools"
yum update.

We use nomachine v. 4.4.6 for users to connect to the CentOS 7 boxes:

rpm -qilf /usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js
Name : gnome-shell-extension-apps-menu
Version : 3.8.4
Release : 10.el7_0


gnome-shell-extension-apps-menu

Regardless of the user (several have tried), (or machine tried 2) when the Applications menu is used there is no action on the click of a menu item.

When line 77 of extension.js:
        this._app.open_new_window(event.get_time());

is hacked to:
        this._app.open_new_window(-1);

The menu items work. Not sure if this hack affects anything? Not sure what the error shown in /var/log/messages below means:

Feb 18 12:09:58 machine gnome-session: JS ERROR: !!! Exception was: Error: can't convert event.get_time() to an integer
Feb 18 12:09:58 machine gnome-session: JS ERROR: !!! message = '"can't convert event.get_time() to an integer"'
Feb 18 12:09:58 machine gnome-session: JS ERROR: !!! fileName = '"/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js"'
Feb 18 12:09:58 machine gnome-session: JS ERROR: !!! lineNumber = '77'
Feb 18 12:09:58 machine gnome-session: JS ERROR: !!! stack = '"([object GObject_Union])@/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js:77
Feb 18 12:09:58 machine gnome-session: wrapper([object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
Feb 18 12:09:58 machine gnome-session: ([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/popupMenu.js:87
Feb 18 12:09:58 machine gnome-session: wrapper([object GObject_Object],[object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
Feb 18 12:09:58 machine gnome-session: "'
Steps To ReproduceCreate new virtual desktop session using NoMachine. Add a application menu.

extension.js fails on line 77 'can't convert event.get_time() to an integer'.

Other launchers (like places) work and include the event.get_time() call.
Additional InformationWas reported to:
https://bugzilla.gnome.org/show_bug.cgi?id=744759

They state: "You are using version 3.8.x which is too old and not supported anymore by GNOME developers. GNOME developers are no longer working on that older version, so unfortunately there will not be any bug fixes by GNOME developers for the version that you use.

By upgrading to a newer version of GNOME you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of GNOME.

Please feel free to reopen this bug if the problem still occurs with a recent version of GNOME, or feel free to file a bug report in the bug tracking system of your Linux distribution if your distribution still supports your version 3.8.x"
TagsNo tags attached.
abrt_hash
URL
Attached Files

-Relationships
+Relationships

-Notes

~0022464

ronatartifact (reporter)

I suspect that this might be caused by an update to some other package. Gnome was working fine and had not been changed since September 2014.
I just installed the latest batch of patches including a kernel patch - 7.0.1406, firefox 31 and some samba updates.
Gnome stopped working after that with the same message in the logs.

Is there any problem with installing the latest gnome 3.14 from gnome.org ?

~0022473

bmurch (reporter)

The problem is keeping multiple levels of updates. I have several machines with CentOS 7. I would think that a wokring Gnome out of the box should be a goal or a new release like el7?

~0022474

Evolution (administrator)

Apparently in 7.2 gnome will be bumped to 3.14 or so, according to upstream bugzilla. https://bugzilla.redhat.com/show_bug.cgi?id=1174442

~0022475

ronatartifact (reporter)

I was able to reboot the machine in question overnight and that seems to have fixed the problem. I am not sure which patch caused the problem but perhaps in my case a file got dropped on the disk as part of the patch that did not fit with the running OS.
centos-release-7-0.1406.el7.centos.2.5.x86_64 is the update that I suspect but I could be wrong.

It may still work out of the box with the latest Centos kernal batch applied.
It was working OOTB in September when I installed it.

In general, I think Centos 7 is a long way from a production system. A lot of it looks like it was done as a junior programming project on a Friday afternoon with the kids allowed to leave as soon as they handed in the work.

It has added a randomness to computing that I have not seen since the 1960s when hardware and new operating system concepts caused all kinds of random events.

~0022950

defanor (reporter)

Same bug appeared here, CentOS Linux release 7.1.1503 (Core). Recent events include update (just tzdata and tzdata-java) and installation of a few (seemingly unrelated) packages with their dependencies, some of them from epel: gcc-c++, wxGTK-devel, wxGTK3-devel.

~0022951

defanor (reporter)

The problem vanished after reboot.
+Notes

-Issue History
Date Modified Username Field Change
2015-02-19 15:15 bmurch New Issue
2015-03-05 22:14 ronatartifact Note Added: 0022464
2015-03-06 15:36 bmurch Note Added: 0022473
2015-03-06 16:03 Evolution Note Added: 0022474
2015-03-06 16:13 ronatartifact Note Added: 0022475
2015-04-30 10:39 defanor Note Added: 0022950
2015-04-30 12:30 defanor Note Added: 0022951
+Issue History