View Issue Details

IDProjectCategoryView StatusLast Update
0008289Buildsyscommunity buildsyspublic2015-05-05 13:39
Reporterhguemar 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0008289: [Cloud SIG] CBS tags hierarchy
DescriptionImplementation of the following proposal: http://lists.centos.org/pipermail/centos-devel/2015-February/012889.htm

cloud7-el7-common (common stuff that are currently in EPEL) => shared
by all projects
inherited by cloud7-el7-<project>-<release>

As we'll import Kilo packages soon, it is very important to have this hierarchy and be able to provide CentOS users multiple OpenStack releases and maintain them properly.

At this moment we need:
cloud-el7-common
cloud-el7-openstack-juno
cloud-el7-openstack-kilo

I'll take care of retagging the existing builds
TagsNo tags attached.

Activities

alphacc

alphacc

2015-03-10 14:34

developer   ~0022503

Hi,

At the target level :

cloud-e7-common target will have cloud-e7-common-build build tag (which need to inherit from destination) and as default destination cloud-e7-common-testing ?
or we drop -testing and -stable ? This can be an issue for automatic signing and workflow in the future.

All cloud7-project target will need to inherit from cloud-e7-common destination tag. Each one will have is own buildroot ? I think it's the only way to have a clean separation.

So it needs a bit more than reshuffling tags.

Thomas.
alphacc

alphacc

2015-03-13 15:56

developer   ~0022515

to move forward one more info needed :

The default destination tag for all target will be -testing or -candidates ?
(this destination will be used for chain building, so build tag must inherit)

Long term we would need to remove tagged package from -testing/-candidates when they hit the final repository (And the "stable" repository should be a dependency for building)
apevec

apevec

2015-03-18 22:47

reporter   ~0022540

Default destination tag will be -candidate,
CI job will move builds to -testing on success.
hguemar

hguemar

2015-04-01 21:20

reporter   ~0022635

@alphacc: is there any blocker ? we're pretty much done importing kilo into Fedora and we can't get started on CentOS.
If you need help and/or more info, let us know.
hguemar

hguemar

2015-04-07 08:21

reporter   ~0022686

Looks good, thanks you !
alphacc

alphacc

2015-04-07 09:28

developer   ~0022687

$ koji list-targets | grep openstack
cloud6-openstack-common-el6 cloud6-openstack-common-el6-build cloud6-openstack-common-candidate
cloud6-openstack-juno-el6 cloud6-openstack-juno-el6-build cloud6-openstack-juno-candidate
cloud7-openstack-common-el7 cloud7-openstack-common-el7-build cloud7-openstack-common-candidate
cloud7-openstack-juno-el7 cloud7-openstack-juno-el7-build cloud7-openstack-juno-candidate
cloud7-openstack-kilo-el7 cloud7-openstack-kilo-el7-build cloud7-openstack-kilo-candidate

Ok it is now done, just one cosmetic change the dist tag is at the end of target.

let me know if you can build.


For the moment as I have no feedback it inherits from *-common-candidate for shared package.
apevec

apevec

2015-04-18 15:39

reporter   ~0022819

1) minor nit: redundant EL release version info in target/buildroot names: cloud{6,7}-*el{6,7}* but looks like that's consistent with rest of CBS ?

2) Should tag inheritance for common buildroots include -common-candidate ?
  Now it has:
cloud7-openstack-common-el7-build (64)
  └─buildsys7 (6)
  Now if I have BR for a build in common, I have to:
add-pkg to cloud7-openstack-common-el7-build
tag-build specific NVR to cloud7-openstack-common-el7-build
  which is sub-optimal.
alphacc

alphacc

2015-04-20 08:39

developer   ~0022827

1) cause disttag can be completely different (e.g : .infra.)

2) correct, it's fixed.
alphacc

alphacc

2015-05-05 13:39

developer   ~0022995

I am closing this, please reopen if you find other issues.

Issue History

Date Modified Username Field Change
2015-03-10 08:49 hguemar New Issue
2015-03-10 14:34 alphacc Note Added: 0022503
2015-03-13 15:56 alphacc Note Added: 0022515
2015-03-18 22:47 apevec Note Added: 0022540
2015-04-01 21:20 hguemar Note Added: 0022635
2015-04-07 08:21 hguemar Note Added: 0022686
2015-04-07 09:28 alphacc Note Added: 0022687
2015-04-17 13:27 alphacc Note View State: 0022687: private
2015-04-17 13:27 alphacc Note View State: 0022687: public
2015-04-18 15:39 apevec Note Added: 0022819
2015-04-20 08:39 alphacc Note Added: 0022827
2015-05-05 13:39 alphacc Note Added: 0022995
2015-05-05 13:39 alphacc Status new => resolved
2015-05-05 13:39 alphacc Resolution open => fixed