View Issue Details

IDProjectCategoryView StatusLast Update
0008333CentOS-7glib2public2015-03-25 20:55
Reporterservtelecom 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformCentOS 7 CROS7.1OS Version7.1
Product Version7.1-1503 
Target VersionFixed in Version 
Summary0008333: Error starting programs with the new version of glib2
DescriptionHello!
With the release of CentOS 7.0 glib2 who had had compiled programs that worked me well (glib2-2.36.3-5)
Now with the release of glib2-2.40.0-4 gives the following error:

-----------------------------------------------
CRITICAL **: desktop_agnostic_config_schema_get_metadata_option: assertion 'self != NULL' failed

CRITICAL **: desktop_agnostic_config_schema_get_metadata_option: assertion 'self != NULL' failed
ViolaciĆ³n de segmento (`core' generado)
-----------------------------------------------

In this case had compiled avant-window-navigator now with the new version of glib2 not work because glib2 obsoletes many things
CentOS July hoped for in his first version 7.0 funciobana me and believed in CentOS conservaias compatible versions that in early versions utilizais

It would be possible to be compatible glib2-2.36.3-5 be preserved? Maybe I like being a package in his day was created to python27 in CentOS 6 ?? Create a glib236 package?
TagsNo tags attached.
abrt_hash
URL

Activities

tigalch

tigalch

2015-03-24 20:00

manager   ~0022584

Very unlikely. RedHat updated glib2 to 2.40 with the releases of 7.1, so CentOS will also use that version. Since RedHat will not maintain 2.36, we can't do that either. It would be best to adjust your code to work with 2.40 (did you recompile your application?). Maybe this helps: https://rhn.redhat.com/errata/RHBA-2015-0302.html. Or the glib2 documentation for 2.40
servtelecom

servtelecom

2015-03-24 20:49

reporter   ~0022586

too modifying code and a project that has no continuity but I use a lot
I'll have to make reversing and let 7 to return to CentOS CentOS 6 hoping that will not be glib2 version makes my application incompatible
It is a very sad day for me
tigalch

tigalch

2015-03-24 20:56

manager   ~0022587

Just for reference, in CentOS-6 glib2 also changed from 2.22 to 2.28 during the previous minor releases. So some minor changes in glib2 are to be expected.
servtelecom

servtelecom

2015-03-24 21:12

reporter   ~0022588

True but CebtOS 6.6 just try and if it works I qye I stopped using CentOS 7 to return to CentOS 6 I am also very sad
servtelecom

servtelecom

2015-03-25 09:51

reporter  

libdesktop-agnostic-0.3.94-1.el7.src.rpm (231,403 bytes)
servtelecom

servtelecom

2015-03-25 09:55

reporter   ~0022593

happy day for me!!

rebuild package libdesktop-agnostic for code https://github.com/p12tic/libdesktop-agnostic it's ok!

libdesktop-agnostic-0.3.94 works perfectly on my computer and no longer fails to launch applications that depend on libdesktop-agnostic

include the src if someone you can serve it can rebuild for CentOS 7.1 system

I apologize for my English, I'm Spanish
tigalch

tigalch

2015-03-25 20:00

manager   ~0022595

Can we close this issue then?
servtelecom

servtelecom

2015-03-25 20:40

reporter   ~0022596

yes, yes! thank's
tigalch

tigalch

2015-03-25 20:55

manager   ~0022597

Thus closing

Issue History

Date Modified Username Field Change
2015-03-24 10:01 servtelecom New Issue
2015-03-24 20:00 tigalch Note Added: 0022584
2015-03-24 20:49 servtelecom Note Added: 0022586
2015-03-24 20:56 tigalch Note Added: 0022587
2015-03-24 21:12 servtelecom Note Added: 0022588
2015-03-25 09:51 servtelecom File Added: libdesktop-agnostic-0.3.94-1.el7.src.rpm
2015-03-25 09:55 servtelecom Note Added: 0022593
2015-03-25 20:00 tigalch Note Added: 0022595
2015-03-25 20:00 tigalch Status new => feedback
2015-03-25 20:40 servtelecom Note Added: 0022596
2015-03-25 20:40 servtelecom Status feedback => assigned
2015-03-25 20:55 tigalch Note Added: 0022597
2015-03-25 20:55 tigalch Status assigned => resolved
2015-03-25 20:55 tigalch Resolution open => no change required