2017-03-23 18:15 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0008482CentOS-7xorg-x11-serverpublic2016-04-10 19:06
Reporterb-glawe 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
Platformx86_64OSCentosOS Version7.1
Product Version 
Target VersionFixed in Version 
Summary0008482: Constant screen flicker with Firefox browser
DescriptionAny updates of a firefox webpage - like changing content or clicked buttons - result in a very ugly flicker. Sometimes it's only the area of the clicked page element or, sometimes the whole firefox windows (excluding the frame) flickers.
Steps To Reproduceworks with almost any webpage
Additional InformationI'm using the propriatery nvidia driver installed via a additional repository and the firefox that came with Centos 7.1

I had no issues with Centos 7.

I tried the latest firefox 37.0.1 from the mozilla download page and had the same issues, which is why I blame the xorg server / driver and not firefox.

I have not had any comparable issues with any non-Firefox applications.
TagsNo tags attached.
abrt_hash
URL
Attached Files

-Relationships
+Relationships

-Notes

~0023112

JohnnyHughes (administrator)

It was suggested that this was the following upstream bug:

https://bugzilla.gnome.org/show_bug.cgi?id=724788

Here are packages with the upstream patch applied, does this fix your issue:

http://people.centos.org/hughesjr/c71-clutter/x86_64/Packages/

~0023292

BOPOHOK (reporter)

I am experiencing what looks very similar to what OP describes.
Installing http://people.centos.org/hughesjr/c71-clutter/x86_64/Packages/
clutter-1.14.4-12.el7.centos.x86_64.rpm has not helped.

~0023313

BOPOHOK (reporter)

I have to apologize, as my original note (0023292) was in error.
The package by JohnnyHughes is indeed effective and has resolved my flickering issue.

~0023805

BOPOHOK (reporter)

A routine automatic update yesterday has brought the flickering back.
Installing the package by JohnnyHughes (rpm -ihv --force) saves the day again.

~0024680

iainhallam (reporter)

Thanks for the patched version! Does anyone know if there's an upstream bug for this issue, and is it likely to be addressed in the 7 series?

~0024682

iainhallam (reporter)

Incidentally, what commands did you use to make that version? I'd like to get a version yum won't clobber with an update.

~0024918

kimball58 (reporter)

This worked for me, but try at your own risk. I'm running CentOS 7.0.

(1) Installed patched clutter pkg by Johnny Hughes using "rpm -ihv --force"
(2) Uninstalled default version using "yum remove clutter-1.14.4-12.el7_1.1"
(3) Add a new line "exclude=clutter" (without quotes) to the [updates] section of /etc/yum.repos.d/CentOS-Base.repo

Installing the patched version first and then uninstalling the base version avoids the deinstall/reinstall of about 35 dependencies. Editing the .repo file will keep yum from overwriting the patched version.

The clutter-devel and clutter-doc packages were not installed by default, and I did not install the patched versions. If you install them, add corresponding "exclude" entries to the .repo file to keep them from being overwritten.

~0026247

ie_philwyett (reporter)

With 7.2 and newer clutter. Can we mark this as resolved?
+Notes

-Issue History
Date Modified Username Field Change
2015-04-16 08:13 b-glawe New Issue
2015-05-19 13:15 JohnnyHughes Note Added: 0023112
2015-06-04 04:39 BOPOHOK Note Added: 0023292
2015-06-05 07:29 BOPOHOK Note Added: 0023313
2015-08-06 19:18 BOPOHOK Note Added: 0023805
2015-10-22 09:33 iainhallam Note Added: 0024680
2015-10-22 17:02 iainhallam Note Added: 0024682
2015-11-24 22:15 kimball58 Note Added: 0024918
2016-04-10 19:06 ie_philwyett Note Added: 0026247
+Issue History