View Issue Details

IDProjectCategoryView StatusLast Update
0000855CentOS-4Missing Componentpublic2005-04-09 12:09
Reporteruser290Assigned To 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSCentOS 
Product Version4.0 (Final) - i386 
Summary0000855: GLADE Not Working
DescriptionI did a standard install of CentOS 4 (Including Gnome and X). Upon install I use
yum to install glade2. All goes well until I start glade-2. Upon Start, a blank
palette window is created no other windows are created. You cannot close glade.
I then manually compiled glade 2.6.8 by hand and had no problems. What
information can I provide you with?
TagsNo tags attached.

Activities

user290

2005-03-09 22:45

  ~0002494

Last edited: 1970-01-01 00:00

Created an attachment (id=102)
The fully monty

Here is what happens as described in the bug

user313

2005-03-25 18:23

  ~0002495

Last edited: 1970-01-01 00:00

I've confirmed that this behavior is present as well....additionally, when I run
an strace on the glade pid, I get this information. (Important note: this output
loops continuously over and over)

munmap(0xb7d6b000, 4096) = 0
write(3, "<\30\2\0nB \2\232\4\5\0oB \2mB \2.\0\0\0\0\0\0\0006(\2"..., 16368) = 16368
open("/root/.icons/Bluecurve/cursors/xterm", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/root/.icons/Bluecurve/index.theme", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/usr/share/icons/Bluecurve/cursors/xterm", O_RDONLY) = 16
fstat64(16, {st_mode=S_IFREG|0644, st_size=5020, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7d6b000
read(16, "Xcur\20\0\0\0\0\0\1\0\3\0\0\0\2\0\375\377\30\0\0\0004\0"..., 4096) = 4096
_llseek(16, 0, [0], SEEK_SET) = 0
read(16, "Xcur\20\0\0\0\0\0\1\0\3\0\0\0\2\0\375\377\30\0\0\0004\0"..., 4096) = 4096
close(16) = 0
munmap(0xb7d6b000, 4096) = 0
Process 5243 detached
JohnnyHughes

JohnnyHughes

2005-04-06 12:02

administrator   ~0002496

Last edited: 1970-01-01 00:00

This is reproducable on the i386 and x86_64 arches when rebuilding the SRPM
glade2-2.6.0-1.src.rpm.

This issue is reported upstream now at:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=153977
herrold

herrold

2005-04-06 16:43

reporter   ~0002498

Last edited: 1970-01-01 00:00

possible patch from Parsley:

ftp://dist.taolinux.org/pub/incoming/parsley/glade-infinite-loop.patch

          --.--K/s --- glade-2.6.7/glade/glade_atk.c
2004-10-12 10:00:42.000000000 -0400
+++ glade-2.6.8/glade/glade_atk.c 2004-12-20 20:11:28.000000000 -0500
@@ -605,7 +605,9 @@
 {
   GtkWidget *page, *icon, *vbox, *table;
   GdkPixbuf *pixbuf;
- AtkRelationType relationship;
+ /* Don't use AtkRelationType here since new values can be registered
+ dynamically, which can cause problems with optimizing compilers. */
+ int relationship;

   page = gtk_scrolled_window_new (NULL, NULL);
   gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (page),
JohnnyHughes

JohnnyHughes

2005-04-07 01:24

administrator   ~0002499

Last edited: 1970-01-01 00:00

This bug has been fixed with version glade2-2.6.0-1.centos4.src.rpm, now
available from the centos mirrors.
JohnnyHughes

JohnnyHughes

2005-04-09 12:09

administrator   ~0002500

Last edited: 1970-01-01 00:00

*** Bug 834 has been marked as a duplicate of this bug. ***

Issue History

Date Modified Username Field Change
2005-04-06 12:02 JohnnyHughes Status NEW => ASSIGNED
2005-04-06 16:42 herrold CC => herrold@owlriver.com
2005-04-07 01:24 JohnnyHughes Status ASSIGNED => RESOLVED
2005-04-07 01:24 JohnnyHughes Resolution => FIXED
2005-04-09 12:09 JohnnyHughes CC => l_still@bellsouth.net